Joomla! critical exploit

There’s an exploit available in the wild for Joomla! version 2.5.13 and earlier 2.5.x versions; and version 3.1.4 and earlier 3.x versions.
The exploit allows an attacker to bypass file upload restrictions (so someone could for example upload a PHP file). It’s recommended to upgrade to version 2.5.14 or 3.1.5.

More information:
http://developer.joomla.org/security/news/563-20130801-core-unauthorised-uploads